Can StackExchange admins fix configuration for this site to enable syntax highlighting on https://ethereum.stackexchange.com ?

EDIT: This is not a duplicate for How do I turn on python syntax highlighting? because the problem is obviously in web site config - not in something users can do.

  • 1
    Possible duplicate of How do I turn on python syntax highlighting? – Richard Horrocks Jun 16 at 14:19
  • I think there were a couple of follow-up questions too. For example: ethereum.meta.stackexchange.com/questions/554/… – Richard Horrocks Jun 16 at 14:19
  • And this previous answer was asking about Javascript: ethereum.meta.stackexchange.com/a/515/52 – Richard Horrocks Jun 16 at 14:20
  • Having said all this... nothing seems to have been addressed :-) – Richard Horrocks Jun 16 at 14:21
  • With regards to the edit, I still think this is a duplicate. The Google Code Prettify engine used for syntax highlighting works by reading any tags the question has to determine the language being used. If the question doesn't have any question tags to use as hints, then the author can add a <-- language ... --> tag above the code to tell the highlighter which language is being used. This is what is being tried in the duplicate question. – Richard Horrocks Jun 17 at 8:23
  • The fact that this isn't working means that something bigger is the issue, and this is the question being implicitly asked in those other posts. From the duplicate: "Maybe syntax highlighting is off site-wide?" And from the Javascript answer I mentioned: "...so I assumed that syntax highlighting is turned off on this site. Is it?" – Richard Horrocks Jun 17 at 8:24
  • If you follow the link provided, the syntax highlighting doesn't work regardless of tags and explicit language tag. – Anatoli Babenia Jun 18 at 4:11
  • 2
    To clarify to both of you: syntax highlighting is off by default on all new sites, and is turned on if the community asks for and demonstrates a need for it to be enabled. I'll have someone look at it. – animuson Jun 18 at 13:47
up vote 1 down vote accepted

This now seems to be working for posts that contain the appropriate tags :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .